summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-10-03 23:18:56 +0200
committerhaawda2018-10-03 23:18:56 +0200
commite5c0af68b4020a22fda464b00fd2646fe3c636c7 (patch)
tree1f2f849fe8ec0790b2ad7adc11adc4a639e3fb20 /PKGBUILD
downloadaur-e5c0af68b4020a22fda464b00fd2646fe3c636c7.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..215e46368a9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-commander
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Command line parsing for emacs"
+arch=('any')
+url="https://github.com/rejeep/commander.el.git"
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rejeep/commander.el/archive/v$pkgver.tar.gz")
+sha256sums=('5eb0f7f016b484ffc91bcd54ced1b0455667e5ee93077a92eafc9d5f4214daa4')
+
+build() {
+ cd commander.el-${pkgver}
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd commander.el-${pkgver}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+}