summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Whitt2017-04-27 09:35:23 -0400
committerAlex Whitt2017-04-27 09:35:23 -0400
commit3fb5617947c24d2f0385bb83853a4823fb19971f (patch)
treea6c0d9496e2b64216b66ccbba29b9e3b3e6d813f /PKGBUILD
downloadaur-3fb5617947c24d2f0385bb83853a4823fb19971f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fab49a696ece
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-company-mode
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="Modular in-buffer completion framework for Emacs"
+url="http://company-mode.github.io"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-company-mode')
+source=("https://github.com/company-mode/company-mode/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/company-mode-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/company-mode-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/company-mode"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/company-mode/"
+}