summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-04-09 18:02:24 +0200
committerhaawda2018-04-09 18:02:24 +0200
commit7319aed134d515d442d81dc1c0184785309d147f (patch)
tree80e747cc715982bdc6cfd9ee3ac0115111d4b0d7 /PKGBUILD
parent3fb5617947c24d2f0385bb83853a4823fb19971f (diff)
downloadaur-7319aed134d515d442d81dc1c0184785309d147f.tar.gz
adopted and updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fab49a696ece..2460a4d5665d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-company-mode
-pkgver=0.9.3
+pkgver=0.9.4
pkgrel=1
pkgdesc="Modular in-buffer completion framework for Emacs"
url="http://company-mode.github.io"
@@ -10,16 +11,16 @@ license=('GPL3')
depends=('emacs')
makedepends=('git')
provides=('emacs-company-mode')
-source=("https://github.com/company-mode/company-mode/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/company-mode/company-mode/archive/${pkgver}.tar.gz")
+sha256sums=('fd2662a452aa31644d0e7615e9aeff236f0c8e09b13b0371c400b1b0bc0d1e73')
build() {
- cd "${srcdir}/company-mode-${pkgver}"
+ cd company-mode-${pkgver}
emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
}
package() {
- cd "${srcdir}/company-mode-${pkgver}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/company-mode"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/company-mode/"
+ cd company-mode-${pkgver}
+ install -d "${pkgdir}"/usr/share/emacs/site-lisp/company-mode
+ install -m644 *.el{c,} "${pkgdir}"/usr/share/emacs/site-lisp/company-mode/
}