summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEsben Haabendal2019-10-30 11:47:51 +0100
committerEsben Haabendal2019-10-30 11:47:51 +0100
commite197a11be093d23a9cde7052388693cfcf64ede4 (patch)
tree791ac2f1f1dbce6e7ca4424d880bbf13449af88c /PKGBUILD
parentb59b94a0c6c99da8f4a620f80e1a02a897f9736d (diff)
downloadaur-e197a11be093d23a9cde7052388693cfcf64ede4.tar.gz
Fixup and update to 0.8.1.r4.59c734af576b
Strip 'v' prefix from tag when generating version. Fix editorconfig-core-c dependency (only -git variant exists at this point in time).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23a69cd10856..efc1f0b9258b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Esben Haabendal <esben@haabendal.dk>
pkgname=emacs-editorconfig-git
-pkgver=v0.7.11.r35.e314a7cb6437
+pkgver=0.8.1.r4.59c734af576b
pkgrel=1
pkgdesc="EditorConfig Emacs Plugin"
arch=('any')
@@ -9,7 +9,7 @@ _github_org="editorconfig"
_github_repo="editorconfig-emacs"
url="http://github.com/${_github_org}/${_github_repo}"
license=('GPL3')
-depends=('emacs' 'editorconfig-core-c')
+depends=('emacs' 'editorconfig-core-c-git')
makedepends=('git')
provides=('emacs-editorconfig')
install="${pkgname}.install"
@@ -18,7 +18,7 @@ md5sums=('SKIP')
pkgver() {
cd "$_github_repo"
- printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {