summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Whitt2017-05-01 11:49:32 -0400
committerAlex Whitt2017-05-01 11:49:32 -0400
commit96209fc946c1894fedda63ca55cea32e1fe362ab (patch)
treeb4356c81f9db751be916d10c59fb6b85ec47c600 /PKGBUILD
downloadaur-96209fc946c1894fedda63ca55cea32e1fe362ab.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06d8f9826d11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-evil-iedit-state
+pkgver=1.1
+pkgrel=1
+pkgdesc="Slick Evil states for iedit."
+arch=(any)
+url="https://github.com/syl20bnr/evil-iedit-state"
+license=('GPL3')
+depends=('emacs' 'emacs-iedit')
+optdepends=('emacs-expand-region: Integration with expand-region')
+source=("https://github.com/syl20bnr/evil-iedit-state/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/evil-iedit-state-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/evil-iedit-state-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/evil-iedit-state/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/evil-iedit-state/"
+}