summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsballert2018-09-04 16:06:17 +0200
committersballert2018-09-04 16:06:17 +0200
commit92dbe85f20dd042bb61b876b74c08c6709c7e225 (patch)
treece72181337e58c3607409d4b9bffcda7b8da0d1b /PKGBUILD
downloadaur-92dbe85f20dd042bb61b876b74c08c6709c7e225.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fc6e9782472
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="flycheck"
+_gitrepo="flycheck"
+
+pkgname=emacs-flycheck-git
+pkgver=r4529.ef2dcc12
+pkgrel=1
+pkgdesc="On the fly syntax checking for GNU Emacs"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-dash' 'emacs-pkg-info')
+makedepends=('git')
+provides=('emacs-flycheck')
+conflicts=('emacs-flycheck')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}