summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsballert2018-09-06 14:24:33 +0200
committersballert2018-09-06 14:24:33 +0200
commitae7d66f681775d00f97f272b042a427fbb91ff55 (patch)
treeaaeaea8bf6834be751af89cc5ff764433fa5ef4d /PKGBUILD
downloadaur-emacs-flyspell-correct-ivy-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a2b2abe93d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="d12frosted"
+_gitrepo="flyspell-correct"
+
+pkgname=emacs-flyspell-correct-ivy-git
+pkgver=r70.0486912
+pkgrel=1
+pkgdesc="This package provides ivy interface for flyspell-correct package."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-flyspell-correct')
+makedepends=('git')
+provides=('emacs-flyspell-correct-ivy')
+conflicts=('emacs-flyspell-correct-ivy')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile flyspell-correct-ivy.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 flyspell-correct-ivy.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}