summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-08-25 21:25:54 +0200
committerhaawda2018-08-25 21:25:54 +0200
commit274f6c9ad4c16026003855050217945e4dbb0b75 (patch)
tree251d1638c4027ca71c3280a685aaf0eb3cf2bab6 /PKGBUILD
parent805af578a891e19af82609eea36293950cd1f534 (diff)
downloadaur-emacs-font-lock-plus.tar.gz
adopted, updated, and added pkgver function. Pull from emacswiki, not github.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20a91abe5da4..449659ae14f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
pkgname=emacs-font-lock-plus
-pkgver=208
+pkgver=218
pkgrel=1
pkgdesc="Enhancements to standard library 'font-lock.el'."
url="https://www.emacswiki.org/emacs/font-lock%2B.el"
arch=('any')
license=('GPL2')
depends=('emacs')
-makedepends=('git')
+makedepends=('git' 'awk')
provides=('emacs-font-lock-plus')
-source=("https://github.com/emacsmirror/font-lock-plus/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("font-lock+.el::https://www.emacswiki.org/emacs/download/font-lock%2B.el")
+sha256sums=('e4ce731106a5baef872bf03ad5ee30bcfa7f163102813a60e1552e48ecf72705')
+pkgver() {
+ awk '/Update #:/ {print $4}' font-lock+.el
+}
+
build() {
- cd "${srcdir}/font-lock-plus-${pkgver}"
- emacs -Q -batch -L . -f batch-byte-compile *.el
+ emacs -Q -batch -L . -f batch-byte-compile font-lock+.el
}
package() {
- cd "${srcdir}/font-lock-plus-${pkgver}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/font-lock-plus/"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/font-lock-plus/"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/font-lock-plus/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/font-lock-plus/
}