summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Whitt2017-04-25 15:51:10 -0400
committerAlex Whitt2017-04-25 15:51:10 -0400
commit805af578a891e19af82609eea36293950cd1f534 (patch)
tree5485fe49241ed1ed032ac6e1c3d560ba611108bf /PKGBUILD
downloadaur-805af578a891e19af82609eea36293950cd1f534.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20a91abe5da4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-font-lock-plus
+pkgver=208
+pkgrel=1
+pkgdesc="Enhancements to standard library 'font-lock.el'."
+url="https://www.emacswiki.org/emacs/font-lock%2B.el"
+arch=('any')
+license=('GPL2')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-font-lock-plus')
+source=("https://github.com/emacsmirror/font-lock-plus/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/font-lock-plus-${pkgver}"
+ emacs -Q -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/font-lock-plus-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/font-lock-plus/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/font-lock-plus/"
+}