summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRasmus Villemoes2024-06-12 11:29:22 +0200
committerEsben Haabendal2024-06-12 14:50:41 +0200
commit6402d0692bef4d02bef0239f823a55f15b19b9f6 (patch)
treef25af8d03711403b475cc8a81a49738c5dcd74ae /PKGBUILD
parent25ecfcf9fc8e595527d757d28f5e542297d5aa26 (diff)
downloadaur-6402d0692bef4d02bef0239f823a55f15b19b9f6.tar.gz
Fix makeinfo output directory change
At some point makeinfo changed default output dir from {basename} to {basename}_html . Add a patch to use an explicit dir name. Signed-off-by: Rasmus Villemoes <rv@rasmusvillemoes.dk>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a241d1387c76..e7c04a16325c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,15 @@ license=('GPL3')
depends=('emacs' 'emacs-dash' 'emacs-graphql' 'emacs-treepy')
makedepends=('git' 'texlive-core')
provides=('emacs-ghub')
-source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=v${pkgver}")
-md5sums=('SKIP')
+source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=v${pkgver}"
+ "0001-make-Explicitly-specify-output-directory-for-makeinf.patch")
+md5sums=('0111387a567e4bf62ccbc46e897e1dae'
+ '777222ee44c8da9f78a1e10bc3c4d714')
+
+prepare() {
+ cd "$srcdir/${_github_repo}"
+ patch --strip=1 --input=../0001-make-Explicitly-specify-output-directory-for-makeinf.patch
+}
build() {
cd "$srcdir/${_github_repo}"