summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Whitt2017-05-01 13:01:35 -0400
committerAlex Whitt2017-05-01 13:01:35 -0400
commit1abb984370ae269c311fc5df93b8d1b68edd92e9 (patch)
tree675f841dfe719c9a53276f16f6a6c252f152b747 /PKGBUILD
parentf9c83b7e710c38d3fa68ee61f3d32fc82c6b5054 (diff)
downloadaur-1abb984370ae269c311fc5df93b8d1b68edd92e9.tar.gz
Switching to a more up-to-date fork
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bebfcf363a8a..5b53dbdfb2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,23 @@
# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
pkgname=emacs-iedit
-pkgver=0.90
-pkgrel=3
+pkgver=0.9.9.9
+pkgrel=1
pkgdesc="Edit multiple regions with the same content simultaneously"
arch=(any)
-url="https://github.com/tsdh/iedit"
+url="https://github.com/victorhge/iedit"
license=('GPL3')
depends=('emacs')
-source=("https://github.com/tsdh/iedit/archive/${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/tsdh/iedit/master/iedit-lib.el"
- "https://raw.githubusercontent.com/tsdh/iedit/master/iedit-rect.el")
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+source=("https://github.com/victorhge/iedit/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
build() {
- emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
-
cd "${srcdir}/iedit-${pkgver}"
- emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+ emacs -q --no-splash -batch -L . -f batch-byte-compile iedit{-lib,-rect,}*.el
}
package() {
mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
-
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
-
cd "${srcdir}/iedit-${pkgver}"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
+ install -m644 iedit{-lib,-rect,}.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
}