summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Whitt2017-05-01 12:10:01 -0400
committerAlex Whitt2017-05-01 12:10:01 -0400
commit367edfa792dd41e180a9de2ea6a6769e8c860eba (patch)
treefafe9fcd9d285c64e37716e0036a969154515db3 /PKGBUILD
parente2e1fb96f1a7da340b8fb5584cb84b32120f3b4f (diff)
downloadaur-367edfa792dd41e180a9de2ea6a6769e8c860eba.tar.gz
Adding iedit-lib.el, which for some reason is not included in the release tarball.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffcc43a0007a..0f8418f3c8f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,28 @@
pkgname=emacs-iedit
pkgver=0.90
-pkgrel=1
+pkgrel=2
pkgdesc="Edit multiple regions with the same content simultaneously"
arch=(any)
url="https://github.com/tsdh/iedit"
license=('GPL3')
depends=('emacs')
-source=("https://github.com/tsdh/iedit/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("https://github.com/tsdh/iedit/archive/${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/tsdh/iedit/master/iedit-lib.el")
+sha256sums=('SKIP' 'SKIP')
build() {
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+
cd "${srcdir}/iedit-${pkgver}"
emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
}
package() {
- cd "${srcdir}/iedit-${pkgver}"
mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
+
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
+
+ cd "${srcdir}/iedit-${pkgver}"
install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/iedit/"
}