summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Whitt2017-05-02 10:03:44 -0400
committerAlex Whitt2017-05-02 10:03:44 -0400
commit2129425422ced61d77a2abb8d5a802ba2cf5fc2d (patch)
treeba237791168a60bea524fbf1bfaf5b1912386ba5 /PKGBUILD
parente1da6b71385b55926534ee8958b84ce944c15c8e (diff)
downloadaur-2129425422ced61d77a2abb8d5a802ba2cf5fc2d.tar.gz
Updating to master HEAD. There are changes there that are required for counsel-jedi to work. Also deleting the tarball... not sure how that got in there.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67e7949d6758..4a01e4161cad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
pkgname=emacs-jedi
pkgver=0.2.7
-pkgrel=2
+pkgrel=3
pkgdesc="Python auto-completion for Emacs"
url="https://github.com/tkf/emacs-jedi"
arch=('any')
license=('GPL3')
-depends=('emacs' 'python-jedi' 'emacs-auto-complete' 'emacs-epc' 'emacs-python-environment')
+depends=('emacs' 'python-jedi' 'emacs-auto-complete' 'emacs-epc' 'emacs-python-environment' 'python-virtualenv')
makedepends=('git')
provides=('emacs-jedi')
-source=("https://github.com/tkf/emacs-jedi/archive/v${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tkf/emacs-jedi/archive/master.zip")
sha256sums=('SKIP')
build() {
- cd "${srcdir}/emacs-jedi-${pkgver}"
+ cd "${srcdir}/emacs-jedi-master"
emacs -q --no-splash -batch -L . -f batch-byte-compile jedi*.el
}
package() {
- cd "${srcdir}/emacs-jedi-${pkgver}"
+ cd "${srcdir}/emacs-jedi-master"
install -d "${pkgdir}/usr/share/emacs/site-lisp/jedi"
install -m644 jedi*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/jedi/"
install -m755 jedi*.py "${pkgdir}/usr/share/emacs/site-lisp/jedi/"