summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNoel Maersk2017-12-20 18:59:30 +0200
committerNoel Maersk2017-12-20 18:59:30 +0200
commitd4aa3979ab579164ff70a7fc02b1bd753e9c183c (patch)
tree0e30c4f7973a0cd2d5b66c99dbdddf696b5e4711 /PKGBUILD
downloadaur-d4aa3979ab579164ff70a7fc02b1bd753e9c183c.tar.gz
Initial versioned release.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81f79f67cc27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Noel Maersk <veox plus packages the veox toad pw>
+
+pkgname=emacs-lll-mode-git
+pkgver=v0.1.0.r0.gdecc55c
+pkgrel=1
+pkgdesc='An emacs major mode for editing Ethereum LLL code'
+arch=('x86_64')
+url='https://github.com/robmyers/lll-mode'
+license=('GPLv3')
+makedepends=('git')
+depends=('emacs')
+install=${pkgname}.install
+provides=('emacs-lll-mode')
+conflicts=('emacs-lll-mode')
+source=("$pkgname"::'git+https://gitlab.com/veox/emacs-lll-mode.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'v-' prefix that presents in the git tag
+ git describe --long | sed 's/^v-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/share/emacs/site-lisp/lll-mode
+ install -Dm644 *.el $pkgdir/usr/share/emacs/site-lisp/lll-mode
+}