summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2019-10-21 05:33:46 +0200
committerhaawda2019-10-21 05:33:46 +0200
commit7a045c60731592ff24d18e9b89f55dbec00362a4 (patch)
treeaec192fc8f14084e26c5f7a547d23ab00969ac35 /PKGBUILD
parented6e5e52157cce11ce5b48989e0b72a348b4828f (diff)
downloadaur-7a045c60731592ff24d18e9b89f55dbec00362a4.tar.gz
use cask for building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 505ed126ce9a..2e4c8a39d94c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,14 @@ pkgdesc="Emacs client/library for the Language Server Protocol"
url="https://github.com/${_gituser}/${_gitrepo}"
arch=('any')
license=('GPL3')
-depends=('emacs')
+depends=('emacs-ht')
+makedepends=('cask')
source=("$pkgname-$pkgver.tar.gz::https://github.com/${_gituser}/${_gitrepo}/archive/$pkgver.tar.gz")
sha256sums=('7c502ac206ea66b69f32015ac9e0e62a107bc8ecc2371756080914a561cae7e7')
build() {
cd ${_gitrepo}-$pkgver
- emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+ cask build
}
package() {