summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEsben Haabendal2017-12-15 21:28:21 +0100
committerEsben Haabendal2017-12-15 21:28:21 +0100
commitfa18314109ace6f14c630908a8542e0ccf5046d3 (patch)
treea7025295faac104d3cf9ce148d4cd4c9a9f02863 /PKGBUILD
downloadaur-fa18314109ace6f14c630908a8542e0ccf5046d3.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fae81cff29a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Esben Haabendal <esben@haabendal.dk>
+
+pkgname=emacs-magit-popup
+_github_org="magit"
+_github_repo="magit-popup"
+pkgver=2.12.0
+pkgrel=1
+pkgdesc="A generic interface for toggling switches and setting options and then invoking an Emacs command which does something with these arguments"
+arch=('any')
+url="http://github.com/${_github_org}/${_github_repo}"
+license=('GPL3')
+depends=('emacs>=24.4' 'emacs-dash=2.13.0')
+makedepends=('git')
+provides=('emacs-magit-popup')
+install="${pkgname}.install"
+source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/${_github_repo}"
+ unset EMACS
+ make LOAD_PATH="-L /usr/share/emacs/site-lisp/dash" \
+ lisp info
+}
+
+package() {
+ cd "$srcdir/${_github_repo}"
+ mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
+ install -m 644 magit-popup.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
+ mkdir -p ${pkgdir}/usr/share/info
+ install -m 644 magit-popup.info ${pkgdir}/usr/share/info/
+}