summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorÉtienne Deparis2016-12-16 12:25:08 +0100
committerÉtienne Deparis2016-12-16 12:25:08 +0100
commit90562b3586ecbdce4191eb57f679891213264013 (patch)
treeffb1e98071c546dd6fe08f6fddf6ff46e9905d01 /PKGBUILD
parent897d57d5852cdfe09bf2dc819aa72ae5cb2af4db (diff)
downloadaur-90562b3586ecbdce4191eb57f679891213264013.tar.gz
New pkgbuild version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fec3bb7be03..4d3fc4f194a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,26 @@
pkgname=emacs-multiple-cursors
_pkgname=multiple-cursors
-pkgver=1.3.0
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
pkgdesc="Multiple cursors for Emacs"
-arch=('any')
+arch=("any")
url="https://github.com/magnars/multiple-cursors.el"
-license=('GPL3')
+license=("GPL3")
install=$pkgname.install
-depends=('emacs')
+depends=("emacs")
source=("https://github.com/magnars/$_pkgname.el/archive/$pkgver.tar.gz")
-md5sums=('b60faec04a10f911289cf40828c4ac80')
+sha256sums=('33a1c193cf8bcb0c80f71a154cbbc1956ee80a79ec63ebcaf3ea6fb6298c3042')
build() {
cd $srcdir/$_pkgname.el-$pkgver/
- emacs -batch -f batch-byte-compile *.el
+ for file in $(find . -maxdepth 1 -type f -name '*.el'); do
+ emacs -Q --batch --eval "(progn (load-file \"multiple-cursors-core.el\")(load-file \"mc-mark-more.el\")(byte-compile-file \"${file}\"))"
+ done
}
+
+
package() {
cd $srcdir/$_pkgname.el-$pkgver/
install -d -m755 $pkgdir/usr/share/emacs/site-lisp/multiple-cursors