summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPoscat2019-11-08 10:16:40 +0800
committerPoscat2019-11-08 10:16:40 +0800
commit1161a07df2f62eadef53ea107ae44d2225dbe5a2 (patch)
tree63f0d8e2508522764cbf3f26b73fae2818066f85 /PKGBUILD
downloadaur-1161a07df2f62eadef53ea107ae44d2225dbe5a2.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b34c623271af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Poscat <poscat@mail.poscat.moe>
+
+pkgname=emacs-onedark-theme-git
+pkgver=r154.623fc08
+pkgrel=1
+pkgdesc="An Emacs port of the Atom One Dark theme."
+arch=('x86_64')
+url="https://github.com/jonathanchu/atom-one-dark-theme"
+license=('GPL3')
+provides=('emacs-onedark-theme')
+conflicts=()
+makedepends=('git')
+depends=('emacs')
+source=("${pkgname}::git://github.com/jonathanchu/atom-one-dark-theme")
+noextract=()
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git submodule update --init
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -D -m 644 atom-one-dark-theme.el "${pkgdir}/usr/share/emacs/site-lisp/onedark-theme/atom-one-dark-theme.el"
+}