summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManoel Vilela2016-11-25 21:47:46 -0300
committerManoel Vilela2016-11-25 21:47:46 -0300
commitc536b8543ec045be8d7717c057a732c08ef46524 (patch)
tree319e81d32dac045fd35efa8a85df48f9d4f9c007 /PKGBUILD
downloadaur-c536b8543ec045be8d7717c057a732c08ef46524.tar.gz
Add first version of emacs-openrc
Ported from gentoo using a simplified version without emacs bin wrapper. I need get some vars to put on defaults, like SHELL, HOME and USER. As the service start as root and the final user is not him, I need do some hacking here. Sorry for this shit :( BTW, in some way, this works.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43d02ccaf037
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Manoel Vilela <manoel_vilela@engineer.com>
+
+pkgname="emacs-openrc"
+pkgver="1.0"
+pkgrel=1
+pkgdesc="Init script for emacs daemon for openrc"
+arch=('i686' 'x86_64')
+license=('GPL3')
+groups=()
+depends=("emacs" "openrc")
+makedepends=()
+optdepends=()
+provides=('openrc-emacs')
+conflicts=('openrc-emacs')
+replaces=('openrc-emacs')
+backup=()
+options=()
+install="$pkgname.install"
+changelog="CHANGELOG"
+source=()
+noextract=("emacs-daemon.rc")
+
+package() {
+ # Creating need directories
+ install -dm755 "$pkgdir/etc/init.d"
+ install -Dm755 "emacs-daemon.rc" $pkgdir/etc/init.d/emacs
+}