summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2019-10-12 12:56:31 +0200
committerhaawda2019-10-12 12:56:31 +0200
commit1da13c6cebd6d4983e5bc3337c669385d18f065c (patch)
tree0f0bd05e3f27c288501bff8ef4042318d710aa55 /PKGBUILD
downloadaur-1da13c6cebd6d4983e5bc3337c669385d18f065c.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5de60ef17165
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+_pkgsrcname=parseclj
+_pkgmaintainer=clojure-emacs
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Associative data structure functions for elisp"
+pkgname=emacs-parseclj
+arch=('any')
+url="https://github.com/${_pkgmaintainer}/a.el"
+license=('GPL3')
+depends=('emacs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/v${pkgver}.tar.gz")
+sha256sums=('8948ecd47b6cbd06ca869694b7afdbe4cbca5bb47ab685358656afea7f6389ce')
+
+build() {
+ cd ${_pkgsrcname}-${pkgver}
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd ${_pkgsrcname}-${pkgver}
+ install -d "${pkgdir}"/usr/share/emacs/site-lisp/
+ install -m644 *.el{c,} "${pkgdir}"/usr/share/emacs/site-lisp
+}