summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Fryers2022-09-28 10:21:19 +0100
committerTom Fryers2022-09-28 10:21:19 +0100
commit3c1b4f2e037564d928e03c1df169171d37f51b22 (patch)
treeb854540106b4d25cb586167b80d7bf32f8721ffc /PKGBUILD
parent7ed3fc44447aadefd6bf37e9110d3c4dde262c79 (diff)
downloadaur-3c1b4f2e037564d928e03c1df169171d37f51b22.tar.gz
Update from upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 815e912c2eef..a723b6de58f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,8 +42,12 @@ JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
#
# To compile all site-lisp on demand (repos/AUR packages,
# ELPA, MELPA, whatever), add
- # (setq comp-deferred-compilation t)
+ # (setq native-comp-deferred-compilation t)
# to your .emacs file.
+ #
+ # And to keep the eln cache clean add
+ # (setq native-compile-prune-cache t)
+ # to delete old versions.
AOT="YES" # Compile all elisp files.
@@ -88,7 +92,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-pgtk-native-comp-git"
fi
-pkgver=29.0.50.157962
+pkgver=29.0.50.160160
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -99,7 +103,6 @@ depends=("${depends_nox[@]}" 'harfbuzz')
makedepends=('git')
provides=('emacs')
replaces=('emacs')
-#source=("emacs-git::git://git.savannah.gnu.org/emacs.git"
source=("emacs-git::git+https://github.com/emacs-mirror/emacs.git"
"nemacs")
options=(!strip)