summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorP.A. López-Valencia2016-04-23 13:05:20 -0500
committerP.A. López-Valencia2016-04-23 13:05:20 -0500
commit06d965e71b8ec747b873dcf194406bd153112cde (patch)
treedfd2047e172826da293b9d6f68a37469200d2e3f /PKGBUILD
parent8cb374ef4cbb76d0d67b0174c9fb8af0c6f3bccf (diff)
downloadaur-06d965e71b8ec747b873dcf194406bd153112cde.tar.gz
emacs-pretest-25.0.93-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a7ad31ee787..9e27d9ae1213 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,33 @@
pkgname=emacs-pretest
_pkgname=emacs
-pkgver=25.0.92
-pkgrel=3
+pkgver=25.0.93
+pkgrel=1
pkgdesc="The extensible, customizable, self-documenting real-time display editor -- pretest version"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('gtk3' 'gpm' 'giflib' 'm17n-lib' 'desktop-file-utils' 'alsa-lib' 'imagemagick')
+depends=('gtk3' 'gpm' 'giflib' 'm17n-lib' 'desktop-file-utils' 'alsa-lib' 'imagemagick' 'zlib')
install=$pkgname.install
provides=('emacs')
conflicts=('emacs')
source=(ftp://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$pkgver.tar.xz{,.sig})
-sha384sums=('1d8f0a4aa0bb51589f917c5d7f639ce6fa483b60e6b74ef2e13294b3ce6ad7295cf9823693dd626e65f9c89fda028c1d'
+sha384sums=('b2fc25d2018573161bd2745d568189b276109c0d1eeec275093be19a0cffce0cfc6db045bac9bb8a4c80c0ab4e825abb'
'SKIP')
validpgkkeys=('28D3BED851FDF3AB57FEF93C233587A47C207910')
build() {
cd "$srcdir"/$_pkgname-$pkgver
- local confopts=(--prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var
- --with-x-toolkit=gtk3 --with-xft --without-gconf)
+ local confopts=(--prefix=/usr
+ --sysconfdir=/etc
+ --libexecdir=/usr/lib
+ --localstatedir=/var
+ --without-gconf
+ --with-sound=alsa
+ --with-x-toolkit=gtk3
+ --with-game-user=:games
+ --with-modules)
./configure "${confopts[@]}"
make
}