summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-12-03 09:21:38 -0500
committerPedro A. López-Valencia2021-12-03 09:21:38 -0500
commit10d88b4bef0babdf728e3aa2040f4b4db5ec7f8c (patch)
treeb5093ce0f528c9f783a672226443c116ede1ce82 /PKGBUILD
parent10d8c18abc102205a718f7e7110e8487b990f11c (diff)
downloadaur-10d88b4bef0babdf728e3aa2040f4b4db5ec7f8c.tar.gz
* 28.0.90
* Add libgccjit depency and enable native ELISP compilation.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 36 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f2e76505eb2..741f17755988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,42 +5,55 @@
pkgname=emacs-pretest
_pkgname=emacs
-pkgver=27.0
-_pkgver=27.0.91
-pkgrel=0.91
+pkgver=28.0
+_pkgver=28.0.90
+pkgrel=0.90
pkgdesc="The extensible, customizable, self-documenting real-time display editor -- pretest version"
arch=('x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('gpm' 'm17n-lib' 'gtk3' 'jansson')
+depends=(
+ 'gpm'
+ 'gtk3'
+ 'jansson'
+ 'giflib'
+ 'libgccjit'
+)
provides=('emacs')
conflicts=('emacs')
-source=(https://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$_pkgver.tar.xz{,.sig})
-sha512sums=('fcae087c7d153ce45640dc5785e0829e85b14400eec70f833e1f7ee7d3903f1e4adb469d812596fc6e7ff792ccaeda3fde5fa1c37b609ab83e8432d9f63be36a'
- 'SKIP')
-validpgpkeys=('28D3BED851FDF3AB57FEF93C233587A47C207910')
+# PGP keyservers are all but dead. PGP signatures are useless for all practical purpose. Kudos to the EU.
+#source=(https://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$_pkgver.tar.xz{,.sig}) # PGP keyserver are all but dead.
+#validpgpkeys=('28D3BED851FDF3AB57FEF93C233587A47C207910')
+source=(https://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$_pkgver.tar.xz)
+b2sums=('51bb58a0bb2d1dbe7dc0cf490d9a66f1028ec2291db18782ebeb64df29117a6230f1c46b71842fbc0935f50060536b58522d235bb0ee4333c0f137fde7407141')
build() {
cd "$srcdir"/$_pkgname-$_pkgver
local confopts=(
- --prefix=/usr
- --sysconfdir=/etc
- --libexecdir=/usr/lib
- --localstatedir=/var
- --with-gameuser=root:games
- --with-x-toolkit=gtk3
- --with-xft
- --with-modules
- --without-compress-install
+ --prefix=/usr
+ --sysconfdir=/etc
+ --libexecdir=/usr/lib
+ --localstatedir=/var
+ --with-gameuser=root:games
+ --with-x-toolkit=gtk3
+ --with-xft
+ --with-harfbuzz
+ --with-modules
+ --without-compress-install
+ --without-m17n-flt
+ --without-libotf
+ --without-imagemagick
# Beware https://debbugs.gnu.org/cgi/bugreport.cgi?bug=25228
# dconf and gconf break font settings set in ~/.emacs
# If you insist you'll need to play gymnastics with
# set-frame-font and set-menu-font. Good luck!
# Might be fixed in master, but you can't be be too cautious. Try emacs-git first.
- --without-gsettings
- --without-gconf
- )
+ --without-gsettings
+ --without-gconf
+# Welcome to the new world.
+ --with-native-compilation
+)
./configure "${confopts[@]}"
make
}
@@ -63,3 +76,6 @@ package() {
chown -R root:games "$pkgdir"/var/games
}
+
+################################################################################
+# vim:set ft=bash ts=2 sw=2 et: