summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author78099+palopezv@users.noreply.github.com2020-03-05 06:13:59 -0500
committer78099+palopezv@users.noreply.github.com2020-03-05 06:13:59 -0500
commit5d8dccb1faa67698021f722da4888687497dabe7 (patch)
tree38fbcaa084a5a7c38e0fc924fbaf8bbe549d57f8 /PKGBUILD
parent6da0e1470a68d20c7003111df82f789ede615e07 (diff)
downloadaur-5d8dccb1faa67698021f722da4888687497dabe7.tar.gz
27.0.90
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24dd8818d57c..190c0c40c368 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,23 @@
pkgname=emacs-pretest
_pkgname=emacs
-pkgver=26.3
-_pkgver=26.3-rc1
-pkgrel=0.1
+pkgver=27.0
+_pkgver=27.0.90
+pkgrel=0.90
pkgdesc="The extensible, customizable, self-documenting real-time display editor -- pretest version"
arch=('x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
-depends=('gpm' 'm17n-lib' 'gtk3' 'libmagick6')
+depends=('gpm' 'm17n-lib' 'gtk3' 'imagemagick')
provides=('emacs')
conflicts=('emacs')
source=(https://alpha.gnu.org/gnu/emacs/pretest/$_pkgname-$_pkgver.tar.xz{,.sig})
-sha512sums=('4d5a4319253afb081e105a3697eb6eeb8d8a0da18cd41346e376ca5af1e180a26e641f76c64fad1b0253168f14a511f0a4d9d4141524fb1cf4d04f25b05a76e9'
+sha512sums=('1a6f319e964f20ad35574eb2d2e18ae8c86d9d2ab9ae038334f0f468c40602d1f9b20880cfa704ea2067bdd7a3952ea3e6b565d5bb3d6d304922ad1d98c1c76b'
'SKIP')
validpgpkeys=('B29426DEFB07724C3C35E5D36592E9A3A0B0F199' '28D3BED851FDF3AB57FEF93C233587A47C207910' 'D405AA2C862C54F17EEE6BE0E8BCD7866AFCF978')
build() {
- cd "$srcdir"/$_pkgname-$pkgver
-
-# Force imagemagick6 detection.
-export PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig
+ cd "$srcdir"/$_pkgname-$_pkgver
local confopts=(
--prefix=/usr
@@ -40,7 +37,7 @@ export PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig
# dconf and gconf break font settings set in ~/.emacs
# If you insist you'll need to play gymnastics with
# set-frame-font and set-menu-font. Good luck!
-# Seems to be fixed in master. Try emacs-git.
+# Might be fixed in master, but you can't be be too cautious. Try emacs-git first.
--without-gsettings
--without-gconf
)
@@ -49,7 +46,7 @@ export PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig
}
package() {
- cd "$srcdir"/$_pkgname-$pkgver
+ cd "$srcdir"/$_pkgname-$_pkgver
make DESTDIR="$pkgdir" install
# remove conflict with ctags package