summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsballert2018-09-02 12:23:51 +0200
committersballert2018-09-02 12:23:51 +0200
commit9e6d23aad4923cd325a04b77b718a8a906b28850 (patch)
tree1791c201357732d11999346ed964812c93136eb7 /PKGBUILD
downloadaur-9e6d23aad4923cd325a04b77b718a8a906b28850.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9e9f6d72029
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="magnars"
+_gitrepo="s.el"
+
+pkgname=emacs-s-git
+pkgver=r258.03410e6
+pkgrel=1
+pkgdesc="The long lost Emacs string manipulation library."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-s')
+conflicts=('emacs-s')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/s/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/s/
+}