summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsumito34782015-06-30 06:27:32 +0900
committersumito34782015-06-30 06:27:57 +0900
commit0e81c8ddd1e5abdbd84b4b7df1af8efbec5e390b (patch)
tree945e9eac865c13ed5e9ee23b19e148591454c7d6 /PKGBUILD
downloadaur-0e81c8ddd1e5abdbd84b4b7df1af8efbec5e390b.tar.gz
feat(aur): move directory aur to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b05e02be67b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: sumito3478 <sumito3478@gmail.com>
+pkgname=emacs-scala-mode-git
+pkgver=20150424
+pkgrel=1
+pkgdesc="Scala-mode for emacs, from the official Scala Github repository"
+arch=('any')
+url="https://github.com/scala/scala-tool-support/tree/master/tool-support/emacs"
+license=('BSD')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-scala-mode')
+conflicts=('emacs-scala-mode')
+install=install.sh
+
+_gitroot="https://github.com/scala/scala-tool-support.git"
+_gitname=scala-dist
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+
+ cd "$srcdir/$_gitname"
+ cd "tool-support/emacs"
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ cd "tool-support/emacs"
+
+ install -d -m755 ${pkgdir}/usr/share/emacs/scala-mode/ || return 1
+ install -D -m644 *.elc ${pkgdir}/usr/share/emacs/scala-mode/ || return 1
+}
+
+# vim:set ts=2 sw=2 et: