summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Husmann2015-11-20 14:40:58 +0100
committerStefan Husmann2015-11-20 14:40:58 +0100
commit2ae0a4e0a1d1c3b7ad99c6b2c993f78816ec3a84 (patch)
treea0117bd18d359a13617f5f78127c97e94235e06f /PKGBUILD
downloadaur-2ae0a4e0a1d1c3b7ad99c6b2c993f78816ec3a84.tar.gz
rename from sly-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdea55a471ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-sly-git
+pkgver=1.0.0.beta.156.g5ec1b93
+pkgrel=1
+pkgdesc="Common Lisp IDE for Emacs. Fork of slime."
+arch=('any')
+url="https://github.com/capitaomorte/sly"
+license=('custom')
+depends=('emacs' 'gawk')
+makedepends=('git')
+provides=('sly')
+conflicts=('sly')
+source=("emacs-sly::git+https://github.com/capitaomorte/sly.git")
+md5sums=('SKIP')
+_gitname="emacs-sly"
+options=('!makeflags')
+
+pkgver() {
+ cd "$srcdir"/"$_gitname"
+ echo $(git describe --tags | sed 's|-|.|g')
+}
+
+prepare () {
+ cd "$srcdir"/"$_gitname"/contrib
+ # some files cannot be byte-compiled
+ mv sly-fancy.el doof1
+ mv sly-stickers.el doof2
+}
+
+build() {
+ cd "$srcdir"/"$_gitname"
+ make
+ # reverting the prepare step to include the not byte-compiled files
+ cd contrib
+ mv doof1 sly-fancy.el
+ mv doof2 sly-stickers.el
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -d $pkgdir/usr/share/emacs/site-lisp/sly
+ cp -r $srcdir/$_gitname/* \
+ $pkgdir/usr/share/emacs/site-lisp/sly
+ install -D -m644 README.md \
+ $pkgdir/usr/share/licenses/$pkgname/public_domain.txt
+}