summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJon Eyolfson2017-01-14 14:52:24 -0500
committerJon Eyolfson2017-01-14 14:52:24 -0500
commit9d04042054092628236b2e0f243b76d27a568fe2 (patch)
tree62c0b1a3b1f0e25b0d4f1348fcd0c4a3a7183621 /PKGBUILD
parentebec7b19fcde95a4c41954292f64517814a7a378 (diff)
downloadaur-9d04042054092628236b2e0f243b76d27a568fe2.tar.gz
Update to 0.6.6-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fa955e62fca..cf50828092aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
# Contributor: listx <linusarver <at> gmail <dot> com>
pkgname=emacs-undo-tree
-pkgver=0.6.4
+pkgver=0.6.6
pkgrel=1
pkgdesc="Replace Emacs' undo system with an intuitive tree-based system."
arch=('any')
-url="http://www.dr-qubit.org/emacs.php#undo-tree"
+url="http://www.dr-qubit.org/tags/computing-code-emacs.html"
depends=('emacs')
license=('GPL')
provides=('emacs-undo-tree')
conflicts=('emacs-undo-tree')
install=$pkgname.install
-source=(http://www.dr-qubit.org/undo-tree/undo-tree-${pkgver}.el)
-sha1sums=('117764e599bcacd3e364e071854f53aeec33ef09')
+source=("$pkgname"::'git+http://www.dr-qubit.org/git/undo-tree.git#tag=release/0.6.6')
+sha256sums=('SKIP')
build() {
- # rename to just undo-tree.el
- mv undo-tree-${pkgver}.el undo-tree.el
- # compile for speed
+ cd "${srcdir}/${pkgname}"
emacs -batch -f batch-byte-compile undo-tree.el
}
package() {
# create destination path
- install -d $pkgdir/usr/share/emacs/site-lisp
+ install -d $pkgdir/usr/share/emacs/site-lisp/undo-tree
# copy over file into path
- cp $srcdir/undo-tree.{el,elc} $pkgdir/usr/share/emacs/site-lisp
+ cp "${srcdir}/${pkgname}/undo-tree."{el,elc} $pkgdir/usr/share/emacs/site-lisp/undo-tree
}