summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorP.A. López-Valencia2016-11-14 09:03:27 -0500
committerP.A. López-Valencia2016-11-14 09:03:27 -0500
commit72a97e7ef95d434fc857acec3690954ede8b1f46 (patch)
treeedc23e710a8cbfbffd305946fb42670b2ef81502 /PKGBUILD
parentf4a2572803c00585a6a5a39493210a9ac7b15263 (diff)
downloadaur-72a97e7ef95d434fc857acec3690954ede8b1f46.tar.gz
Fix new emacs.service file. Installation is broken by default in Arch.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8682321b79fd..e8ecdb313387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,7 +42,7 @@ DOCS_PDF= # Generate and install pdf documentation.
#######################################################################
pkgname=emacs-git
-pkgver=26.0.50.127317
+pkgver=26.0.50.127403
pkgrel=1
pkgdesc="GNU Emacs. Master development branch."
arch=('i686' 'x86_64')
@@ -169,6 +169,13 @@ package() {
chmod 775 "$pkgdir"/var/games
chmod 775 "$pkgdir"/var/games/emacs
chown -R root:games "$pkgdir"/var/games
+
+ # The logic used to install systemd's user service is partially broken
+ # under Arch Linux model, because it adds $DESTDIR as prefix to the
+ # final Exec targets. The fix is to hack it with an axe.
+ install -Dm644 etc/emacs.service "$pkgdir"/usr/lib/systemd/user/emacs.service
+ sed -i -e 's#\(ExecStart\=\)#\1\/usr\/bin\/#' -e 's#\(ExecStop\=\)#\1\/usr\/bin\/#' \
+ "$pkgdir"/usr/lib/systemd/user/emacs.service
}
# vim:set ft=sh ts=2 sw=2 et: