summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlejandro López-Valencia2017-10-13 11:15:17 -0500
committerAlejandro López-Valencia2017-10-13 11:15:17 -0500
commitdea94ac3207955ad762231cee598de50defd2bdc (patch)
tree9b55378ee7f0b8be6dfc4fba355cb33cc3dfd6e3 /PKGBUILD
parent81f3088eec20f4a1ea8b5a7b84a148b6dcdd5ab4 (diff)
downloadaur-dea94ac3207955ad762231cee598de50defd2bdc.tar.gz
Add option to track master or a different branch if desired.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c99c12dda1e..9ef80412c68d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,22 @@
#######################################################################
#######################################################################
+# Track a maintenance branch or by default track master.
+#
+# Pick a branch from the output of "git branch" ran on your local copy
+# of the emacs repository.
+#
+# E.g.:
+# BRANCH=master
+# BRANCH=emacs-26
+# BRANCH=emacs-25
+# BRANCH=emacs-24
+# BRANCH=emacs-23
+# BRANCH=xwidget # If you are a glutton for punishment
+#
+BRANCH=master
+
+#######################################################################
# Assign "YES" to the variable you want enabled; empty or other value
# for NO.
#
@@ -38,9 +54,9 @@ NOGZ="YES" # Don't compress el files. Info and man pages are
#######################################################################
pkgname=emacs-git
-pkgver=26.0.50.130000
+pkgver=27.0.50.130834
pkgrel=1
-pkgdesc="GNU Emacs. Master development branch."
+pkgdesc="GNU Emacs. Development."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/"
license=('GPL3')
@@ -115,9 +131,8 @@ fi
#######################################################################
conflicts=('emacs')
provides=('emacs')
-#source=("$pkgname::git://git.savannah.gnu.org/emacs.git#branch=master")
-#source=("$pkgname::git+https://git.savannah.gnu.org/git/emacs.git#branch=master")
-source=("$pkgname::git+https://github.com/emacs-mirror/emacs.git")
+ #source=("$pkgname::git://git.savannah.gnu.org/emacs.git#branch=$BRANCH")
+ source=("$pkgname::git+https://github.com/emacs-mirror/emacs.git#branch=$BRANCH")
md5sums=('SKIP')
pkgver() {