summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-01-02 13:37:24 -0500
committerPedro A. López-Valencia2021-01-02 13:37:24 -0500
commit11c00cd931d70bae7dde21ad2d3e27dab740c7aa (patch)
tree7e1673432f9a1eb1a796f585a62a072ad1d379a4 /PKGBUILD
parentc1a0f5527631fa808c2a2775800ccace743d200e (diff)
downloadaur-11c00cd931d70bae7dde21ad2d3e27dab740c7aa.tar.gz
Fix LTO conditional, thanks to Hi-Angel.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9af358881bf9..a4b7fbcaf915 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,7 @@ NOGZ="YES" # Don't compress .el files.
################################################################################
pkgname="emacs-git"
-pkgver=28.0.50.141336
+pkgver=28.0.50.144634
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64' )
@@ -92,12 +92,14 @@ if [[ $CLANG == "YES" ]]; then
makedepends+=( 'clang' 'lld' 'llvm') ;
fi
-if [[ $LTO == "YES" ]] && [[ $CLANG != "YES" ]]; then
+if [[ $LTO == "YES" ]]; then
+ if [[ $CLANG != "YES" ]]; then
CFLAGS+=" -flto -fuse-linker-plugin"
CXXFLAGS+=" -flto -fuse-linker-plugin"
else
CFLAGS+=" -flto"
CXXFLAGS+=" -flto"
+ fi
fi
if [[ $NOTKIT == "YES" ]]; then