summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpancho horrillo2022-04-27 09:48:37 +0200
committerpancho horrillo2022-04-27 09:52:28 +0200
commit70b567f060f3eaa309190b50c14d242e15a0c3bd (patch)
tree6aa1e942a74a530354affe968f062ac18fe72c96 /PKGBUILD
parentc9103cf60690d1619b86c944cd8c245d0c3c7612 (diff)
downloadaur-70b567f060f3eaa309190b50c14d242e15a0c3bd.tar.gz
Minor tweaks
- Use a build directory (as emacs-git does now) - Allow stripping of the debug symbols - Drop unused/duplicated options - Add libsystemd dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 24 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9418c7b724f..36b5e066571d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,17 @@
# https://lists.gnu.org/archive/html/emacs-devel/2021-09/msg02290.html
pkgname=emacs28-git
-pkgver=28.1.50.151262
+pkgver=28.1.50.151319
pkgrel=1
pkgdesc='The extensible, customizable, self-documenting real-time display editor, emacs-28 release branch'
arch=(x86_64)
url=http://www.gnu.org/software/emacs/
license=(GPL3)
-depends=(alsa-lib cairo giflib gnutls gtk3 harfbuzz jansson libjpeg-turbo libgccjit libxml2 libxpm)
+depends=(alsa-lib cairo giflib gnutls gtk3 harfbuzz jansson libjpeg-turbo libgccjit libsystemd libxml2 libxpm)
makedepends=(git xorgproto texlive-core)
provides=(emacs)
conflicts=(emacs emacs-nox emacs-git)
replaces=(emacs emacs-nox emacs-git)
-options=(!strip)
source=($pkgname::git+https://git.savannah.gnu.org/git/emacs.git#branch=emacs-28)
b2sums=(SKIP)
@@ -30,39 +29,40 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
[[ -x configure ]] || ./autogen.sh git && ./autogen.sh autoconf
+ mkdir -p "$srcdir/$pkgname"/build
}
build() {
- cd "$srcdir/$pkgname"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --with-sound=alsa \
- --with-modules \
- --without-libotf \
- --without-m17n-flt \
- --without-gconf \
- --without-gsettings \
- --with-native-compilation \
- --with-x-toolkit=gtk3 --without-xaw3d \
- --with-sound=alsa \
- --without-gpm \
- --without-compress-install \
+ local _confflags=(
+ --prefix=/usr
+ --sysconfdir=/etc
+ --libexecdir=/usr/lib
+ --localstatedir=/var
+ --with-modules
+ --without-libotf
+ --without-m17n-flt
+ --without-gconf
+ --without-gsettings
+ --with-native-compilation
+ --with-x-toolkit=gtk3
+ --without-xaw3d
+ --without-gpm
+ --without-compress-install
--program-transform-name='s/^ctags$/ctags.emacs/'
+ )
+ cd "$srcdir/$pkgname"/build
+ ../configure "${_confflags[@]}"
make NATIVE_FULL_AOT=1
make html
make pdf
}
_check() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname"/build
make check
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" install{,-html,-pdf}
+ cd "$srcdir/$pkgname"/build
+ make DESTDIR="$pkgdir"/ install{,-html,-pdf}
}