summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPedro A. López-Valencia2021-12-03 09:44:30 -0500
committerPedro A. López-Valencia2021-12-03 09:44:30 -0500
commite9e7598df346b12dc1c1542246e1f2b87cc0a9bb (patch)
tree04a15a0040db30dd3c475710d8915cdcc425ee28 /PKGBUILD
parent48b2a70e648ff5cfc4c75636ee1f2338150b7791 (diff)
downloadaur-e9e7598df346b12dc1c1542246e1f2b87cc0a9bb.tar.gz
* 29.0.50.152025
* When choosing no graphical toolkit, drop fontconfig. All hail bitmap fonts! 1337!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d62721dc680e..f9bb504072bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,6 +42,7 @@ AOT= # Precompile all included elisp. It takes a long time.
CLI= # CLI only binary.
NOTKIT= # Use no toolkit widgets. Like B&W Twm (001d sk00l).
+ # Bitmap fonts only, 1337!
LUCID= # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
#
@@ -69,7 +70,7 @@ if [[ $CLI == "YES" ]] ; then
else
pkgname="emacs-git"
fi
-pkgver=29.0.50.152302
+pkgver=29.0.50.152306
pkgrel=1
pkgdesc="GNU Emacs. Development master branch."
arch=('x86_64')
@@ -228,7 +229,7 @@ fi
if [[ $CLI == "YES" ]]; then
_conf+=( '--without-x' '--with-x-toolkit=no' '--without-xft' '--without-lcms2' '--without-rsvg' '--without-jpeg' '--without-gif' '--without-tiff' '--without-png' );
elif [[ $NOTKIT == "YES" ]]; then
- _conf+=( '--with-x-toolkit=no' '--without-toolkit-scroll-bars' '--with-xft' '--without-xaw3d' );
+ _conf+=( '--with-x-toolkit=no' '--without-toolkit-scroll-bars' '--without-xft' '--without-xaw3d' );
elif [[ $LUCID == "YES" ]]; then
_conf+=( '--with-x-toolkit=lucid' '--with-xft' '--with-xaw3d' );
else
@@ -306,4 +307,4 @@ package() {
}
################################################################################
-# vim:set ft=sh ts=2 sw=2 et:
+# vim:set ft=bash ts=2 sw=2 et: