summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2015-12-30 00:34:33 +0100
committerMaxime Gauduin2015-12-30 00:34:33 +0100
commit6f489ed0ab8c57c85d8f9c0ca729152b106c5253 (patch)
tree66de2a5d4833be735984b8a2dc0ff8fef627c43f /PKGBUILD
parentb9ecf3a20599ecab204b2fdb2279d83265faed13 (diff)
downloadaur-6f489ed0ab8c57c85d8f9c0ca729152b106c5253.tar.gz
emby-server-git 3.0.5782.0.r524.36eed0d-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af0d219a0f55..8bdc7140a9f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Daniel Seymour <dannyseeless@gmail.com>
pkgname=emby-server-git
-pkgver=3.0.5724.4.r89.fd6f675
+pkgver=3.0.5782.0.r524.36eed0d
pkgrel=1
pkgdesc='Bring together your videos, music, photos, and live television'
-arch=('any')
+arch=('i686' 'x86_64' 'armv6h')
url='http://emby.media'
license=('GPL2')
-depends=('ffmpeg' 'imagemagick' 'libmediainfo' 'mono' 'sqlite')
+depends=('ffmpeg' 'imagemagick' 'mono' 'sqlite')
makedepends=('git')
provides=('emby-server')
conflicts=('emby-server')
install='emby-server.install'
-source=("git+https://github.com/MediaBrowser/Emby.git#branch=dev"
+source=('git+https://github.com/MediaBrowser/Emby.git#branch=dev'
'emby-server'
'emby-migrate-database'
'emby-server.conf'
@@ -45,11 +45,13 @@ build(){
/p:Platform='Any CPU' \
/p:OutputPath="${srcdir}/build" \
/t:build MediaBrowser.Mono.sln
+ mono --aot='full' -O='all' ../build/MediaBrowser.Server.Mono.exe
}
package() {
install -dm 755 "${pkgdir}"/{etc/conf.d,usr/{bin,lib/systemd/system}}
cp -dr --no-preserve='ownership' build "${pkgdir}"/usr/lib/emby-server
+ find "${pkgdir}" -type f -name *.dylib -delete
install -m 755 emby-server "${pkgdir}"/usr/bin/
install -m 755 emby-migrate-database "${pkgdir}"/usr/bin/
install -m 644 emby-server.service "${pkgdir}"/usr/lib/systemd/system/