summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorr3b311i0n2018-01-14 17:46:37 +0530
committerHugo Osvaldo Barrera2020-04-21 13:15:56 +0200
commitab6d33767f6c7653ea185e16047b77de10d64513 (patch)
tree94962fee06613783abee0a78215f4059db54963c /PKGBUILD
downloadaur-ab6d33767f6c7653ea185e16047b77de10d64513.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a33abde2b79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=emoji-cli
+pkgver=r42.26e2d67
+pkgrel=1
+pkgdesc="Emoji completion on the command line for ZSH."
+arch=('any')
+url="https://github.com/b4b4r07/${pkgname}"
+license=('MIT')
+depends=('zsh'
+ 'jq'
+ 'fzf')
+makedepends=('git')
+options=('!strip')
+install="emoji-cli.install"
+source=("git+${url}.git"
+ 'LICENCE::http://b4b4r07.mit-license.org')
+sha256sums=('SKIP'
+ '2a7432c70fd0114ee823e94731aec411751c4a7a6728b9841072272bc1270dad')
+
+pkgver(){
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/"
+ install -Dm 644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
+
+ cd "$srcdir/$pkgname"
+ install -Dm 644 "dict/emoji.json" "${pkgdir}/usr/share/zsh/plugins/${pkgname}/dict/emoji.json"
+ install -Dm 644 "emoji-cli"{.plugin,}".zsh" "${pkgdir}/usr/share/zsh/plugins/${pkgname}"
+}