summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBetül Ünlü2018-09-30 21:26:31 +0300
committerBetül Ünlü2018-09-30 21:26:31 +0300
commit8f2d24bb9060b77a9251a7130f68457fb48d456a (patch)
tree52ccc729399833b0cce7440018ff8b661ff0ded9 /PKGBUILD
downloadaur-8f2d24bb9060b77a9251a7130f68457fb48d456a.tar.gz
first release on AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faa4c2907c4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Betül Ünlü < betulunlu0018 ~at~ gmail ~dot~ com >
+
+pkgname=emojicode
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="An open-source, full-blown programming language consisting of emojis"
+arch=('i686' 'x86_64')
+url="https://emojicode.org"
+license=("custom")
+depends=("llvm")
+makedepends=("cmake>=3.5.1" "ninja" "gcc>=7.2" "python>=3.5.2")
+checkdepends=("python>=3.5.2")
+source=("${pkgname}::git+https://github.com/emojicode/emojicode")
+md5sums=("SKIP")
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ mkdir -p build
+ cd build
+ cmake .. -GNinja
+
+ ninja
+}
+
+#check() {
+# cd "${srcdir}/${pkgname}/build"
+# ninja tests
+#}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "${srcdir}/${pkgname}/build"
+ ninja dist
+
+ cd "Emojicode-0.6.0-Linux-${CARCH}"
+
+ pwd
+
+ install -Dm755 "emojicodec" "${pkgdir}/usr/bin/emojicodec"
+
+ install -Dm644 "include/runtime/Runtime.h" "${pkgdir}/usr/local/include/emojicode/runtime/Runtime.h"
+ install -Dm644 "include/s/Data.h" "${pkgdir}/usr/local/include/emojicode/s/Data.h"
+ install -Dm644 "include/s/String.h" "${pkgdir}/usr/local/include/emojicode/s/String.h"
+
+ install -Dm755 "packages/files/interface.emojii" "${pkgdir}/usr/local/EmojicodePackages/files/interface.emojii"
+ install -Dm755 "packages/files/libfiles.a" "${pkgdir}/usr/local/EmojicodePackages/files/libfiles.a"
+ install -Dm755 "packages/runtime/libruntime.a" "${pkgdir}/usr/local/EmojicodePackages/runtime/libruntime.a"
+ install -Dm755 "packages/s/interface.emojii" "${pkgdir}/usr/local/EmojicodePackages/s/interface.emojii"
+ install -Dm755 "packages/s/libs.a" "${pkgdir}/usr/local/EmojicodePackages/s/libs.a"
+ install -Dm755 "packages/sockets/interface.emojii" "${pkgdir}/usr/local/EmojicodePackages/sockets/interface.emojii"
+ install -Dm755 "packages/sockets/libsockets.a" "${pkgdir}/usr/local/EmojicodePackages/sockets/libsockets.a"
+}