summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuke Arms2021-01-09 19:00:19 +1100
committerLuke Arms2021-01-09 19:00:19 +1100
commitd134a558fa8adf607d4636b372fbea4957d7f5f3 (patch)
tree7bb7428383066c3ae0495d0c2c8ea7022d49e990 /PKGBUILD
parent59d3b756889183440f15a16ca502dadd71791e35 (diff)
downloadaur-d134a558fa8adf607d4636b372fbea4957d7f5f3.tar.gz
Patch unqualified emoji pending upstream fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 243c501d4144..be5c4d9cfe1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=emote
pkgver=1.0.1
-pkgrel=2
+pkgrel=3
url="https://github.com/tom-james-watson/Emote"
pkgdesc="Emoji Picker for Linux written in GTK3"
arch=('any')
@@ -11,16 +11,20 @@ depends=('python' 'gtk3' 'python-gobject' 'python-xlib' 'libkeybinder3')
makedepends=('python-setuptools' 'python-pipenv')
source=(
"setup.py"
+ "emojis.patch"
"https://github.com/tom-james-watson/Emote/archive/v${pkgver}.tar.gz"
)
sha512sums=(
'83b6697b96882d3854c0f64a208571bfeec3e6324790e5508a6bd32092c5d462e86fa676c561111d98cce8058f1730303658612427b66daac086236e3e365316'
+ 'd06513f492a91b2140928b9e116be079b5fb09f8df38d84d0697a1791b470155e130dfdd42d9c3a4167771ca8a1e249a2840ff9e72b1d2feb819a223d6d4c340'
'258c6333109571c8d008f8663a6864b9155100ac9afc083aa08008086c748ec6bc9d3711c2f2be9c8cc53c31dcc98cfa9fbeb6b5186301eec5821a546bf90aaa'
)
build() {
# Replace setup.py
mv -f "$srcdir/setup.py" "$srcdir/Emote-$pkgver/setup.py"
+ # Apply emoji patch
+ patch -d "$srcdir/Emote-$pkgver" -p1 <emojis.patch
# Move static files into the library
mv -T "$srcdir/Emote-$pkgver/static" "$srcdir/Emote-$pkgver/emote/static"
# Fix relative paths