summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMewp2016-05-13 18:16:17 +0200
committermewp2016-05-13 18:22:39 +0200
commit06e9b450050ee932e4a10ff39f82d38cf428cef5 (patch)
treee02194d4b370e07785d1cf38f069fb29cedb1b00 /PKGBUILD
downloadaur-06e9b450050ee932e4a10ff39f82d38cf428cef5.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2598d985179e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Mewp <aur.archlinux.org@mewp.pl>
+pkgname=emptyepsilon
+pkgver=2016.05.07
+pkgrel=1
+epoch=
+pkgdesc="Open source spaceship bridge simulator"
+arch=('x86' 'x86_64')
+url="https://github.com/daid/EmptyEpsilon"
+license=('GPL2')
+groups=()
+depends=('sfml')
+makedepends=('cmake' 'git' 'mesa')
+source=("git+https://github.com/daid/EmptyEpsilon.git#tag=EE-2016.05.07"
+ "git+https://github.com/daid/SeriousProton.git#tag=EE-2016.05.07")
+sha256sums=('SKIP' 'SKIP')
+
+build() {
+ cd $srcdir/EmptyEpsilon/
+ cmake -DSERIOUS_PROTON_DIR=../SeriousProton/ \
+ -DCMAKE_CXX_FLAGS='-DINSTALL_PREFIX=\"/usr\"' \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ make
+}
+
+prepare() {
+ patch -Np1 < ../fixes-for-gcc-6.1.1.patch
+ patch -Np1 < ../fixed-version.patch
+}
+
+package() {
+ cd $srcdir/EmptyEpsilon
+ make DESTDIR="$pkgdir/" install
+}
+