summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMewp2017-05-27 10:45:39 +0200
committerMewp2017-05-27 10:45:39 +0200
commit1b15f8c75d626cce7e07e6ad7377ef33089a91e6 (patch)
treea4d45d5ccc8bd43de8a2d2ecf8294974ae21f670 /PKGBUILD
parent46bd769ff7e94b1d98dca111596318de83f4804c (diff)
downloadaur-1b15f8c75d626cce7e07e6ad7377ef33089a91e6.tar.gz
Update to 2017.05.06 release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fea5b1fc476..1970774bd514 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mewp <aur.archlinux.org@mewp.pl>
pkgname=emptyepsilon
-pkgver=2017.01.19
+pkgver=2017.05.06
pkgrel=1
epoch=
pkgdesc="Open source spaceship bridge simulator"
@@ -19,14 +19,13 @@ build() {
cmake -DSERIOUS_PROTON_DIR=../SeriousProton/ \
-DCMAKE_CXX_FLAGS='-DINSTALL_PREFIX=\"/usr\"' \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCPACK_PACKAGE_VERSION_MAJOR=$(echo $pkgver | cut -d. -f1) \
+ -DCPACK_PACKAGE_VERSION_MINOR=$(echo $pkgver | cut -d. -f2) \
+ -DCPACK_PACKAGE_VERSION_PATCH=$(echo $pkgver | cut -d. -f3) \
.
make
}
-prepare() {
- patch -Np1 < ../fixed-version.patch
-}
-
package() {
cd $srcdir/EmptyEpsilon
make DESTDIR="$pkgdir/" install