summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuint Guvernator2021-12-08 11:12:31 +0100
committerVaporeon2021-12-20 08:21:01 +1300
commit8438e0a6a5f909ab4b45389d682e4a81496025b2 (patch)
tree02f5c9a5eeb3336444fa2883f0c7c0c6903f52db /PKGBUILD
parent24f5a54d2367e607013c1c6f801f1cf43c6b48dc (diff)
downloadaur-8438e0a6a5f909ab4b45389d682e4a81496025b2.tar.gz
add -fcommon to CFLAGS to support recent gcc
Since GCC version 10, this code will not build unless `-fcommon` is added to `CFLAGS`, see this comment in the associated upstream issue: https://github.com/mikeryan/ems-flasher/issues/26#issuecomment-812134344 Since the current version of GCC in the Arch repos is 11.1.0, I think this package should set this extra CFLAG when building.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bec576cd5d05..be2419f2084c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,6 +22,7 @@ pkgver() {
build() {
cd "$srcdir"/ems-flasher
./config.sh --prefix /usr
+ sed -i '/^CFLAGS/ s/$/ -fcommon/' Makefile
make
}