summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBkacjios2022-03-20 11:37:08 -0400
committerBkacjios2022-03-20 11:37:08 -0400
commit7ba08f326f5e2b1cb3c226530797693e44276172 (patch)
tree76df879c6b698294ab5e7dd2ddc87ef08db6fd4d /PKGBUILD
parent573e5637595bc2bd0eca70e2c9b3d678b5204da0 (diff)
downloadaur-7ba08f326f5e2b1cb3c226530797693e44276172.tar.gz
Update to 2.10.2 and switch back to tarballs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 815081d37c27..b3f726f44271 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,7 @@
# Contributor: Guillaume Hayot < ghayot at postblue dot info >
pkgname=emulationstation
_gitname=EmulationStation
-# v2.10.0 didn't have a release package made, use commit
-_gitcommit=c9d905c31acf4b92d0a76b76c5cdf49e2b266d43
-pkgver=2.10.1
+pkgver=2.10.2
pkgrel=1
pkgdesc="Emulation Station is a flexible emulator front-end supporting keyboardless navigation and custom system themes."
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -12,7 +10,7 @@ url="https://github.com/RetroPie/EmulationStation"
license=('MIT')
install=emulationstation.install
depends=('vlc' 'alsa-lib' 'sdl2' 'boost-libs' 'freeimage' 'curl' 'libraw' 'libcec' 'rapidjson' 'pugixml')
-makedepends=('cmake' 'boost' 'freetype2' 'curl' 'git')
+makedepends=('cmake' 'boost' 'freetype2' 'curl')
optdepends=('ttf-droid: Fallback fonts for Chinese/Japanese/Korean characters'
'dolphin-emu: GameCube and Wii support'
'mupen64plus: Nintendo 64 support'
@@ -22,25 +20,23 @@ optdepends=('ttf-droid: Fallback fonts for Chinese/Japanese/Korean characters'
'ppsspp-headless: PSP support'
'steam: Steam support')
conflicts=(emulationstation-git)
-source=("git+${url}.git#commit=${_gitcommit}"
+source=("${url}/archive/v$pkgver.tar.gz"
"install.patch"
"pugixml.patch"
"emulationstation.desktop"
"emulationstation.png")
-sha256sums=('SKIP'
+sha256sums=('ceab6ad366c0f1c2325f5688e610292eac5af4859ffcc59cc33d8f16fbae76c5'
'2608b7de63be4d4d117c2712517e3c40df872f6619f08ac9356f13bdc8c179ab'
'e6cb6a134117cb734c69ed86eecd31cfe29b5d52aa3e00b71a614809c1d7e0fe'
'56a68a60577d015224d721ab169f1439d1545a0fdcf1c23eeee599dc49ea51c6'
'ac589d9da5c258226f8de76e99afe2b07ac86030ced90d284d31b51193057f9c')
prepare() {
- cd "${_gitname}"
- git clean -f
- git submodule update --init --recursive
+ rm -rf "${_gitname}-${pkgver}/external/pugixml"
+ rm -rf "${_gitname}-${pkgver}/.gitmodules"
- cd "${srcdir}"
- patch -d "${_gitname}" -Np1 -i "${srcdir}/install.patch"
- patch -d "${_gitname}" -Np1 -i "${srcdir}/pugixml.patch"
+ patch -d "${_gitname}-${pkgver}" -Np1 -i "${srcdir}/install.patch"
+ patch -d "${_gitname}-${pkgver}" -Np1 -i "${srcdir}/pugixml.patch"
}
build() {
@@ -55,19 +51,19 @@ build() {
_cmakeflags='-DUSE_MESA_GLES:BOOL=ON'
fi
- cmake -B "${_gitname}/build" \
- -S "${_gitname}" \
+ cmake -B "${_gitname}-${pkgver}/build" \
+ -S "${_gitname}-${pkgver}" \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_LIBDIR:PATH='lib' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
${_cmakeflags} \
-Wno-dev -Wno-deprecated \
..
- make -C "${_gitname}/build" all
+ make -C "${_gitname}-${pkgver}/build" all
}
package() {
- make -C "${_gitname}/build" DESTDIR="${pkgdir}" install
+ make -C "${_gitname}-${pkgver}/build" DESTDIR="${pkgdir}" install
install -Dm644 "$srcdir/emulationstation.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/emulationstation.png"
install -Dm644 "$srcdir/emulationstation.desktop" "$pkgdir/usr/share/applications/emulationstation.desktop"
}