summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArne Beer2018-03-02 12:31:21 +0100
committerArne Beer2018-03-02 12:31:21 +0100
commita4a7fa138736176e71cef3e67aa9d848bd1c40d9 (patch)
tree87e0482626c7adf95480098905c8669e75bd1691 /PKGBUILD
parentd830c1d844581e4868eb04533acb4f06eaa85eb1 (diff)
downloadaur-a4a7fa138736176e71cef3e67aa9d848bd1c40d9.tar.gz
Newer encarne version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2dbd46cb8714..73060ba57571 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@ pkgname=encarne
pkgver=1.3.1
pkgrel=1
arch=('any')
-pkgdesc='A command scheduler for shells'
+pkgdesc='A command scheduler and manager for shell commands'
license=('MIT')
-depends=('python-daemonize' 'python-terminaltables-git' 'python-colorclass-git' 'mediainfo' 'pueue' 'python-lxml')
+depends=('mediainfo' 'pueue' 'python-lxml' 'python-sqlalchemy' 'python-sqlalchemy-utils' 'python-humanfriendly')
makedepends=('python-setuptools')
provides=('encarne')
conflicts=('encarne-git')
@@ -15,18 +15,20 @@ source=("https://github.com/Nukesor/encarne/archive/${pkgver}.tar.gz")
sha256sums=('SKIP')
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
- # We don't need anything related to git in the package
- rm -rf .git*
+ # We don't need anything related to git in the package
+ rm -rf .git*
- # Install
- python setup.py install --optimize=1 --root="${pkgdir}"
+ # Install
+ python setup.py install --optimize=1 --root="${pkgdir}"
- # Place systemd user service
- install -Dm644 "utils/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -dm777 "${pkgdir}/var/lib/encarne"
- # Install License
- # MIT/X11 license
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Place systemd user service
+ install -Dm644 "utils/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+
+ # Install License
+ # MIT/X11 license
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}