summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBehnam Momeni2017-12-13 12:21:49 +0330
committerBehnam Momeni2017-12-13 12:21:49 +0330
commit4ef7a15d7802f9f8a3a105da8078629a03615217 (patch)
tree6d59c8629e8460aafa7a3ecd83bd5ec5bc5dfeb5 /PKGBUILD
parent5defa058d00f3eefb95d1fa6d0aff7ebc73bb42d (diff)
downloadaur-4ef7a15d7802f9f8a3a105da8078629a03615217.tar.gz
Upgrading to upstream version 2.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c6fccccff3f..3af4b0d287bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('enchant-hspell')
_pkgname=enchant
-pkgver=1.6.1
+pkgver="2.2.0"
pkgrel=1
pkgdesc="An enchant provider plugin which adds support for Hspell backend"
@@ -15,26 +15,18 @@ license=('LGPL')
depends=("enchant-pure" "hspell")
options=('!libtool')
-source=("https://github.com/AbiWord/${_pkgname}/archive/${_pkgname}-${pkgver//./-}.tar.gz"
- "warnings-fix.patch")
-sha512sums=('971462f8228a1033536a461ddcd9d4c124df5e9b791bd0e996173f56909345639e37cec0950ee3d9f320d985249df4b492eda70e659386c160a240c7b8572e06'
- 'a504286ae22ccbc0b3da009c14c8c85506f8b013305808f1dd664f12a346db354d290e9873a54518e3b56687fef75a474e5b385eed4c81f4227bc25d1fc92e7c')
-
-prepare() {
- mv "${srcdir}/${_pkgname}-${_pkgname}-${pkgver//./-}/" "${srcdir}/${_pkgname}-${pkgver}"
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 -i ../warnings-fix.patch
-}
+source=("https://github.com/AbiWord/enchant/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha512sums=('b1e1a579cbb23b5222ff30572022c29df0ed868208e39791dc80584880b5471e68fbafb71c231d99754443fe08633b07d2d79a910be6764771d9afb2fadf9ce1')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- ./autogen.sh
- ./configure --prefix=/usr --enable-static=no --disable-ispell --disable-myspell --disable-aspell --disable-voikko --disable-uspell --disable-zemberek --enable-hspell
+ ./configure --prefix=/usr --enable-static=no --with-hspell=yes --with-aspell=no --with-hunspell=no --with-voikko=no --with-zemberek=no --with-applespell=no
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- install -D -s -m 755 src/hspell/.libs/libenchant_hspell.so "${pkgdir}/usr/lib/enchant/libenchant_hspell.so"
+ install -D -s -m 755 providers/.libs/enchant_hspell.so "${pkgdir}/usr/lib/enchant-2/libenchant_hspell.so"
}