summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBehnam Momeni2017-12-11 21:58:43 +0330
committerBehnam Momeni2017-12-11 21:58:43 +0330
commitb01fd559bd46dd6001a592dca9bbee8e7b7c04f7 (patch)
tree64077cd680effaf4d0c2e060c5c0404897415cab /PKGBUILD
parente1a1fb7852552d40138a5167299c25dca75c3e73 (diff)
downloadaur-b01fd559bd46dd6001a592dca9bbee8e7b7c04f7.tar.gz
Upgrading to upstream version 2.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 6 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e6116b847b7..93daf80ae13f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,7 @@
pkgname=('enchant-pure')
_pkgname=enchant
-pkgver="1.6.1.r74.e412b19"
-_commithash="e412b1998ec0071a5d55fe5f9decd2c4df18b122"
+pkgver="2.1.2"
pkgrel=1
pkgdesc="A wrapper library for pure and generic spell checking for all languages, supporting Aspell and Myspell/Hunspell backend engines"
@@ -13,27 +12,16 @@ url="https://github.com/AbiWord/enchant"
arch=('any')
license=('LGPL')
-depends=('aspell>=0.50.0' 'dbus-glib>=0.62' 'hunspell')
+depends=('aspell>=0.50.0' 'glib2' 'hunspell')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-options=('!libtool')
-source=("enchant-${pkgver}.tar.gz::https://github.com/AbiWord/${_pkgname}/archive/${_commithash}.tar.gz"
- "warnings-fix.patch" "configure.patch")
-sha512sums=('a176d265fed76636da464a0fe7527162ca1d5367f5409dd836eab48f3eae53b1329bf52c33c07d82aba4845f55493801494843363ef4dd35d748b7cc858a4a00'
- '33312d3714eef836764aeab538517fbe5c44b72593ce9d68e4161d22139c0a859c4a619090c454451db3e2c14790b36c50c1f8ebfcbffe4498b6ee4d5a04faaa'
- 'c2b889eb336e44690278768d67464be14a73e24b1bc9078e226efbdc63e4a46e9c86adbc111dc51dbbcac82f0f84a1bb37c612d70067ced0016053a2fd836f77')
-
-prepare() {
- mv "${srcdir}/${_pkgname}-${_commithash}/" "${srcdir}/${_pkgname}-${pkgver}"
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 -i ../warnings-fix.patch
-}
+source=("https://github.com/AbiWord/enchant/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha512sums=('6cb2eeccc617c005998b16ebc33a84a05cec116b26fd679fc1416110821a85a16605c8564672e1168ac6c865cfcca6680005d1219aa615ca1c2393bd523ae0c4')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- ./autogen.sh --prefix=/usr --enable-static=no --disable-ispell --disable-voikko --disable-uspell --disable-hspell --enable-zemberek=no --with-myspell-dir=/usr/share/myspell
- patch -p1 -i ../configure.patch
- ./configure --prefix=/usr --enable-static=no --disable-ispell --disable-voikko --disable-uspell --disable-hspell --enable-zemberek=no --with-myspell-dir=/usr/share/myspell
+ ./configure --prefix=/usr --enable-static=no --with-aspell=yes --with-hunspell=yes --with-voikko=no --with-hspell=no --with-zemberek=no --with-applespell=no
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}