summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Markevich2022-08-12 13:56:17 +0200
committerMichael Markevich2022-08-12 13:56:17 +0200
commit2bf2aa6ed23000b733d1bf0ccdb691b64b16054e (patch)
tree58b68a944aff6d7a8da9fe43068629a1e5778bf6 /PKGBUILD
parent17232cbc987f5e012f6bef86fb02fe5197ce7868 (diff)
downloadaur-2bf2aa6ed23000b733d1bf0ccdb691b64b16054e.tar.gz
Patching original endpoint-verification script to detect encryption status correctly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c89a9cea5274..53a5b519a922 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,23 @@ pkgbase=endpoint-verification
pkgname=("endpoint-verification" "endpoint-verification-chrome")
_pkgver="2022.06.14.c454816986-00"
pkgver="$(tr '-' '_' <<< $_pkgver)"
-pkgrel=3
+pkgrel=4
pkgdesc="Endpoint Verification Helper"
arch=(x86_64)
url="https://chrome.google.com/webstore/detail/endpoint-verification/callobklhcbilhphinckomhgkigmfocg"
license=(unknown)
-sha256sums=("8db7d5b96564aafd038d2e016127c8ebac0cf9480c4cdbeadaaec643c020cd39" "SKIP")
+sha256sums=('8db7d5b96564aafd038d2e016127c8ebac0cf9480c4cdbeadaaec643c020cd39'
+ '50d9e83ef1b9d32265eecc6af9d9b762ad7c29e771e136a743f29740975c4932'
+ 'c6368969bb236156c818eb61f7b22adea048a6d89956397fe64918265f1b2679')
source=("https://packages.cloud.google.com/apt/pool/${pkgbase}_${_pkgver}_amd64_${sha256sums[0]}.deb"
- "endpoint-verification.service")
+ "endpoint-verification.service"
+ "opera.patch")
prepare() {
tar -xf data.tar.gz
mv etc/init.d/endpoint-verification opt/google/endpoint-verification/bin
rmdir etc/init.d
+ patch --directory="$srcdir" --forward --strip=1 --input="${srcdir}/opera.patch"
}
package_endpoint-verification() {