summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhys Perry2022-10-13 18:07:04 +0100
committerRhys Perry2022-10-13 18:07:04 +0100
commitbd659c68b5f9f5a0acc6d9f1164f4874e3950f9e (patch)
tree04954a684ae61a902459ad831e7112c7ba02f2f9 /PKGBUILD
parent35c89c55c682d54dfb7440b0786e457a7bbfff11 (diff)
downloadaur-bd659c68b5f9f5a0acc6d9f1164f4874e3950f9e.tar.gz
Use updated forks/branches - should be merged soon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e452a2265af7..fc9a5c5b6fce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=engine-sim-git
provides=('engine-sim')
conflicts=('engine-sim')
-pkgver=r235.1ca3c6b
+pkgver=r235.af6a219
pkgrel=1
license=('MIT')
pkgdesc='Combustion engine simulator that generates realistic audio.'
@@ -10,18 +10,15 @@ makedepends=('cmake' 'bison' 'boost' 'flex' 'git')
depends=('sdl2' 'sdl2_image')
arch=('any')
url='https://github.com/ange-yaghi/engine-sim'
-source=('git+https://github.com/bobsayshilol/engine-sim.git#branch=runtime-paths'
+source=('git+https://github.com/bobsayshilol/engine-sim.git#branch=sdl-build'
# Submodules
'git+https://github.com/ange-yaghi/csv-io.git'
- 'git+https://github.com/phire/delta-studio.git#branch=clang_linux'
+ 'git+https://github.com/bobsayshilol/delta-studio.git#branch=sdl-build'
'git+https://github.com/ange-yaghi/direct-to-video.git'
'git+https://github.com/ange-yaghi/piranha.git'
'git+https://github.com/ange-yaghi/simple-2d-constraint-solver.git'
- # Patches - misc still has some conflicts so we don't apply yet
- 'events.patch::https://github.com/phire/delta-studio/pull/2.patch'
- 'misc.patch::https://github.com/phire/delta-studio/pull/3.patch'
)
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd engine-sim
@@ -40,9 +37,6 @@ prepare() {
git config "submodule.externals/vendor/dependencies/submodules/${SUBMODULE}.url" "${srcdir}/${SUBMODULE}"
done
git submodule update
-
- cd dependencies/submodules/delta-studio
- git am "${srcdir}/events.patch"
}
build() {