summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNagy Gabor2016-08-16 23:43:57 +0200
committerNagy Gabor2016-08-16 23:50:21 +0200
commit550708c63e7e5fe33ab80acef66143d80136d8ea (patch)
tree3cef70290bb75675ca857b572fdd09389404552d /PKGBUILD
parent9dcb67e35dfe1da1b55089a70154cf8ec3192bb1 (diff)
downloadaur-550708c63e7e5fe33ab80acef66143d80136d8ea.tar.gz
Add GCC6 compatibility
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e7055129b56..ed5efd7abdd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
# Contributor: Nagy Gabor <Gabor.V.Nagy@@gmail.com>
pkgname=enigma_sdl
pkgver=1.21
-pkgrel=1
+pkgrel=2
pkgdesc="Puzzle game inspired by Oxyd on the Atari ST and Rock'n'Roll on the Amiga."
url="http://www.nongnu.org/enigma/"
depends=('libpng' 'sdl_image' 'sdl_mixer' 'sdl_ttf' 'xerces-c' 'xdg-utils' 'curl')
makedepends=('imagemagick')
-source=(http://downloads.sourceforge.net/enigma-game/enigma-$pkgver.tar.gz)
-sha256sums=('d872cf067d8eb560d3bb1cb17245814bc56ac3953ae1f12e2229c8eb6f82ce01')
+source=(http://downloads.sourceforge.net/enigma-game/enigma-$pkgver.tar.gz
+ std-gnu03.patch)
+sha256sums=('d872cf067d8eb560d3bb1cb17245814bc56ac3953ae1f12e2229c8eb6f82ce01'
+ 'a606faf8f2f55c08a9a49a6ec8bce764422b749bb458733a27aba8cb2cf6b78e')
license=('GPL')
arch=('i686' 'x86_64')
build() {
cd $srcdir/enigma-$pkgver
+ patch -Np1 -i $srcdir/std-gnu03.patch
+ autoconf
./configure --prefix=/usr --program-suffix=_sdl --sysconfdir=/etc --disable-sdltest --enable-optimize
make
}