summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhalosghost2020-10-30 22:04:03 -0500
committerhalosghost2020-10-30 22:04:03 -0500
commit307f71a82b2ba92b87dd9408dd447ed1a558a790 (patch)
tree826cadb07cb1d5603133f75ad3aa41033e666f09 /PKGBUILD
parent1caff6b915fea50caf780b8de16548275c0baa70 (diff)
downloadaur-enlighten-git.tar.gz
Update for new build/configuration/documentation systems
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dd0b2dd79e8..173a10176f3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
pkgname=enlighten-git
-pkgver=0
-pkgrel=2
+pkgver=v0.9.1.r1.gf195a00
+pkgrel=1
pkgdesc='A small tool to modify LCD backlight brightness'
url='https://github.com/HalosGhost/enlighten'
arch=('i686' 'x86_64')
license=('GPL3')
-makedepends=('git' 'clang' 'python-docutils')
+makedepends=('git' 'scdoc')
source=('git+https://github.com/HalosGhost/enlighten.git')
sha256sums=('SKIP')
@@ -26,10 +26,10 @@ prepare () {
build () {
cd enlighten
- make
+ make CONFIGURATION=release bin doc
}
package () {
cd enlighten
- make DESTDIR="$pkgdir" PREFIX="/usr" install
+ make CONFIGURATION=release DESTDIR="$pkgdir" PREFIX="/usr" install
}