summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTadly2015-10-28 14:25:50 +0100
committerTadly2015-10-28 14:25:50 +0100
commit5e081277808a487439660c339be26283bf7ffbf3 (patch)
tree7ab84a589ae823a570a579986db3f9ab03f4a249 /PKGBUILD
parent87ca8064d815efb7dc47dcbeee21753aa70b3544 (diff)
downloadaur-5e081277808a487439660c339be26283bf7ffbf3.tar.gz
using 4 spaces instead of tabs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 25 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc93ba4c9593..6f887e6182af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,36 +9,36 @@ license=('custom')
depends=('libxss')
install=enpass-bin.install
case $CARCH in
- 'x86_64')
- _arch='amd64'
- sha256sums=(
- 'f016afbcf4f5083ed42e0d80f2baa1b1e763b56d8009380de44efb1fa64b593e'
- )
- ;;
- 'i686')
- _arch='i386'
- sha256sums=(
- '6c9140794886b5441c4f82b57c865d1a84955bd87e29bd658546eea0b1343645'
- )
- ;;
+ 'x86_64')
+ _arch='amd64'
+ sha256sums=(
+ 'f016afbcf4f5083ed42e0d80f2baa1b1e763b56d8009380de44efb1fa64b593e'
+ )
+ ;;
+ 'i686')
+ _arch='i386'
+ sha256sums=(
+ '6c9140794886b5441c4f82b57c865d1a84955bd87e29bd658546eea0b1343645'
+ )
+ ;;
esac
source=(http://repo.sinew.in/pool/main/e/enpass/${_pkgname}_${pkgver}_${_arch}.deb)
package() {
- # Extract data
- tar xfz ${srcdir}/data.tar.gz -C ${pkgdir}/
-
- # Remove unnecessary files which are included in the .deb
- find ${pkgdir} -name ".DS_Store" -delete
- find ${pkgdir} -name "._.DS_Store" -delete
- find ${pkgdir} -name "._enpass.png" -delete
+ # Extract data
+ tar xfz ${srcdir}/data.tar.gz -C ${pkgdir}/
- # Update permissions to match the default system ones
- chmod 755 ${pkgdir}/opt/
- find ${pkgdir}/usr/ -type d -exec chmod 755 {} \;
+ # Remove unnecessary files which are included in the .deb
+ find ${pkgdir} -name ".DS_Store" -delete
+ find ${pkgdir} -name "._.DS_Store" -delete
+ find ${pkgdir} -name "._enpass.png" -delete
- # Symlink "runenpass.sh" to "/usr/bin" so it is accessible via terminal
- mkdir -p ${pkgdir}/usr/bin
- ln -s /opt/Enpass/bin/runenpass.sh ${pkgdir}/usr/bin/enpass
+ # Update permissions to match the default system ones
+ chmod 755 ${pkgdir}/opt/
+ find ${pkgdir}/usr/ -type d -exec chmod 755 {} \;
+
+ # Symlink "runenpass.sh" to "/usr/bin" so it is accessible via terminal
+ mkdir -p ${pkgdir}/usr/bin
+ ln -s /opt/Enpass/bin/runenpass.sh ${pkgdir}/usr/bin/enpass
}