summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuke Yeager2019-12-11 09:44:51 -0800
committerLuke Yeager2019-12-11 09:44:51 -0800
commit6c02b0914ae1f8c67b308661106136bee54d38b0 (patch)
tree610e1c731797f282e762eaa55cd2d5d49b214828 /PKGBUILD
parent892ee1faaa67f3de51ae26ff29a6e854c5fe5658 (diff)
downloadaur-6c02b0914ae1f8c67b308661106136bee54d38b0.tar.gz
Make enroot-git package a standard "-git" package
Now, there are two packages: * enroot - latest tagged version (updated manually by pkg owner) * enroot-git - master branch (can be triggered at any time by AUR users)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f0e22682de3..53f896cc7b97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-pkgname='enroot'
+pkgname='enroot-git'
pkgver=2.2.0
-pkgrel=2
+pkgrel=1
pkgdesc='A simple yet powerful tool to turn traditional container/OS images into unprivileged sandboxes.'
url='https://github.com/NVIDIA/enroot'
arch=(x86_64)
@@ -8,10 +8,18 @@ license=(BSD)
makedepends=(git gcc make libtool)
depends=(jq parallel squashfs-tools)
optdepends=(fuse-overlayfs-git libnvidia-container-tools pigz pv squashfuse)
+conflicts=(enroot)
+provides=(enroot)
install='enroot.install'
-source=("git+https://github.com/NVIDIA/enroot.git#tag=v${pkgver}")
+source=("git+https://github.com/NVIDIA/enroot.git#branch=master")
sha256sums=(SKIP)
+pkgver() {
+ cd enroot
+ # Remove leading "v"; add "r" before commit count; convert dashes to dots.
+ git describe --long --tags | sed 's/^v// ; s/\([^-]*-g\)/r\1/ ; s/-/./g'
+}
+
build() {
cd 'enroot'
CPPFLAGS="-DALLOW_SPECULATION -DINHERIT_FDS" make prefix='' exec_prefix=/usr datarootdir=/usr/share
@@ -21,7 +29,7 @@ package() {
cd 'enroot'
DESTDIR="$pkgdir/" make install prefix='' exec_prefix=/usr datarootdir=/usr/share
mkdir -p "${pkgdir}/usr/share/bash-completion/completions"
- mv "${pkgdir}/usr/share/enroot/enroot.bash_completion" "${pkgdir}/usr/share/bash-completion/completions/enroot"
+ mv "${pkgdir}/usr/share/enroot/bash_completion" "${pkgdir}/usr/share/bash-completion/completions/enroot"
}
backup=(etc/enroot/enroot.conf)